Sass Compiler Plugin 3.7.2-SNAPSHOT Release Notes

These are the release notes for Sass Compiler Plugin version 3.7.2-SNAPSHOT.

3.7.2-SNAPSHOT Release Notes

A complete list of issues can be seen in the tracker milestone 3.7.2-SNAPSHOT .

This release features Bourbon version 5.1.0 and Sass version 3.7.3 running on JRuby 9.2.5.0. Please check the full dependencies to find out about the specific Sass and other transitive dependencies included in this release.

New

Enhancements and Fixes

3.7.1 Release Notes

This release features Bourbon version 5.1.0 and Sass version 3.7.3 running on JRuby 9.2.5.0. A complete list of issues can be found in the tracker milestone 3.7.1.

Enhancements and Fixes

  • Update JRuby to 9.2.5.0
  • Update Sass to version 3.7.3, please check the Sass changelog

3.7.0 Release Notes

This release features Bourbon version 5.1.0 and Sass version 3.7.2 running on JRuby 9.2.3.0. A complete list of issues can be found in the tracker milestone 3.7.0.

New

  • Require Maven 3.3.9

Enhancements and Fixes

  • Update JRuby to 9.2.3.0
  • Update Sass to version 3.7.2, please check the Sass changelog
  • Support Maven 3.6.0

3.6.1 Release Notes

This release features Bourbon version 5.1.0 and Sass version 3.6.0 running on JRuby 9.2.0.0. A complete list of issues can be found in the tracker milestone 3.6.1.

Enhancements and Fixes

  • Do not execute lint on empty source list (#222)

3.6.0 Release Notes

This release features Bourbon version 5.1.0 and Sass version 3.6.0 running on JRuby 9.2.0.0. A complete list of issues can be found in the tracker milestone 3.6.0.

Enhancements and Fixes

3.5.5 Release Notes

This release features Bourbon version 5.1.0 and Sass version 3.5.7 running on JRuby 9.2.0.0. A complete list of issues can be found in the tracker milestone 3.5.5.

Enhancements and Fixes

3.5.4 Release Notes

This release features Bourbon version 5.0.0 and Sass version 3.5.6 running on JRuby 9.2.0.0. A complete list of issues can be found in the tracker milestone 3.5.4.

Enhancements and Fixes

  • Update JRuby to 9.2.0.0, this plugin now requires Java 8

3.5.3 Release Notes

This release features Bourbon version 5.0.0 and Sass version 3.5.6 running on JRuby 9.1.16.0. A complete list of issues can be found in the tracker milestone 3.5.3.

Enhancements and Fixes

3.5.2 Release Notes

This release features Bourbon version 5.0.0 and Sass version 3.5.5 running on JRuby 9.1.16.0. A complete list of issues can be found in the tracker milestone 3.5.2.

Enhancements and Fixes

  • Update JRuby to 9.1.16.0
  • Update Bourbon to version 5.0.0, please check the Bourbon changelog
  • Update SCSS-Lint to version 0.57.0, please check the SCSS-Lint changelog
  • Update Sass to version 3.5.5, please check the Sass changelog
  • Use sass-listen instead of listen gem, fixes (#170)

3.5.1 Release Notes

This release features Bourbon version 4.3.4 and Sass version 3.5.4 running on JRuby 9.1.15.0.

A complete list of issues can be found in the tracker milestone 3.5.1.

Enhancements and Fixes

  • Update Sass to version 3.5.4, please check the Sass changelog
  • Update JRuby to 9.1.15.0

3.5.0 Release Notes

This release features Bourbon version 4.3.4 and Sass version 3.5.3 running on JRuby 9.1.13.0.

A complete list of issues can be seen in the tracker milestone 3.5.0 and milestone 3.5-RC1.

New

  • Drop Compass support (#77)

Enhancements and Fixes

3.5-RC1 Release Notes

This release features Bourbon version 4.3.4 and Sass version 3.5.3 running on JRuby 9.1.13.0.

A complete list of issues can be seen in the tracker milestone 3.5-RC1.

NOTE SCSS linting is currently broken, we are waiting for a scss_lint release that supports Sass 3.5.x, see scss-lint #877

New

  • Drop Compass support (#77)

Enhancements and Fixes

Archives of old release notes

There are more release notes (1.x and 2.x versions) in the archive.